Hi expert we have upgraded our Jira data center hosted on AWS from 8.13.8 to 8.13.18. but after upgrade we are getting 502 bad Gateway error. could you please suggest how can we troubleshoot
Hi @Pandey Pradip ,
please check the log file <JIRA-HOME>/log/atlassian-jira.log and provide us he related log error. In my opinion, your app didn't start correctly so 502 error appears.
Fabio
Hi @Fabio Racobaldo _Catworkx_
please see the log. kindly help
@Pandey Pradip , please check if there is some error in that log that avoid your application to start
A 502 usually means that you are running your Jira behind a proxy (Apache or Nginx for example). You have hit the URL for the proxy, the proxy has asked Jira for the first page, and Jira has not responded to it.
This suggests Jira is not running, or returning nothing of any use to the proxy.
You will need to read ALL of your Jira application log to find the errors, or possibly the Tomcat log. The chuck of log you have posted is only a small chunk of a log and you need to be looking at all of it.
I would
stop Jira
Remove or move <Jira data>/logs/atlassian-Jira.log (this is so you get a nice new clean one)
Restart Jira and wait for a couple of minutes.
Read the log - if Jira is completing its start up, you should find a message like "Jira is ready to serve at ....". If it is not, then you will need to read this whole log for errors.
It looks like you're new here. Sign in or register to get started.