Hi Team,
We are Deploying Confluence datacenter on kubernetes in GCP environment and Atlassian support mentioned that managed synchrony will not work in helm chart and have to use standalone by setting enable: true under synchrony in values.yaml file but when we start the synchrony services , got below error
Loading synchrony
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/opt/atlassian/confluence/confluence/WEB-INF/packages/synchrony-standalone.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/opt/atlassian/confluence/confluence/WEB-INF/lib/slf4j-log4j12-1.7.25.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
Starting synchrony
Exception in thread "main" clojure.lang.ExceptionInfo: error while starting state #'synchrony.config/config {:var #'synchrony.config/config}
at mount.lite$start$fn__24142.invoke(lite.clj:153)
at mount.lite$start.invokeStatic(lite.clj:150)
at mount.lite$start.invoke(lite.clj:136)
at mount.lite$start.invokeStatic(lite.clj:141)
at mount.lite$start.invoke(lite.clj:136)
at synchrony.core$start_BANG_.invokeStatic(core.clj:21)
at synchrony.core$start_BANG_.invoke(core.clj:21)
at synchrony.core$_main.invokeStatic(core.clj:42)
at synchrony.core$_main.doInvoke(core.clj:40)
at clojure.lang.RestFn.applyTo(RestFn.java:137)
at synchrony.core.main(Unknown Source)
Caused by: java.net.MalformedURLException: no protocol: qagcp-confleunce.zebra.com
at java.base/java.net.URL.<init>(URL.java:645)
at java.base/java.net.URL.<init>(URL.java:541)
at java.base/java.net.URL.<init>(URL.java:488)
at clojure.java.io$fn__11384.invokeStatic(io.clj:44)
at clojure.java.io$fn__11384.invoke(io.clj:44)
at clojure.java.io$fn__11355$G__11350__11360.invoke(io.clj:35)
at synchrony.config$load_config.invokeStatic(config.clj:70)
at synchrony.config$load_config.invoke(config.clj:63)
at synchrony.config$config_start_BANG_.invokeStatic(config.clj:136)
at synchrony.config$config_start_BANG_.invoke(config.clj:136)
at synchrony.config$fn__24193$fn__24196.invoke(config.clj:138)
at mount.lite.State.start_STAR_(lite.clj:44)
at mount.lite$start$fn__24142.invoke(lite.clj:151)
... 10 more
also we have added below parameters under addtionalajvmparameters but still we are getting SSL PKI error when we use ldaps in user directory for connecting ldap server
- -Djavax.net.ssl.trustStore=/opt/java/openjdk/lib/security/cacerts
- -Djavax.net.ssl.trustStorePassword=XXX
appreciate your help on this.
Thanks,
Sreeni.