Not sure if anyone else has run into this...but I have enabled SSO via SPNEGO/custom authenticator and it turns out the attach screenshot is causing the client side JRE to prompt for username/pass. If you dismiss the popup it just dumps you back to the issue and this shows in Tomcat logs...
Nov 19, 2012 5:00:56 PM net.sourceforge.spnego.SpnegoAuthenticator doBasicAuth
INFO: Username is required.: Login failed. username=; password.hashCode()=0
Any thoughts on how to get around this from others that might have SSO enabled with this method? Can't figure out if I need to focus on the client side or server side...the directory where the attachments are stored has write privs for all JIRA users, there seem to (so far) be no other issues with being prompted once inside the app.