An issue was reported where User A would show up as User B in posts and notifications. Additionally, only one of these two would show up in the User Directory at a time. Ultimately it was discovered that both users had been assigned the same UID in LDAP. Since our Jira user directory is set to sync with LDAP, these accounts could not display correctly in the Atlassian tools simultaneously.
We addressed the core issue by assigning User A a new and unique UID and then resynching the user directory. Both users now appear separately in the Atlassian tools and for several days the issue appeared to be resolved. However, the wrong user appeared on an issue comment today, indicating that some link still exists between these two accounts. I suspect that despite the resync, the old user data may still be cached somewhere.
Has anyone encountered a similar issue or know where old user data could be cached? Any ideas or insight are appreciated.
Using v8.13.3