Hi!
As a test case I tried to import a 3.5.9 exported space into 3.5.17.
We had exported say SPACE1 from our production system and changed entities.xml according to
https://confluence.atlassian.com/display/CONF35/Copy+Or+Rename+A+Space
The import into our production 3.5.9 as say SPACE2 worked perfectly.
When I do the same with 3.5.17 (last 3.5.x) it fails with
Import failed. Check your server logs for more information.
Hibernate operation: could not insert: [com.atlassian.confluence.labels.Labelling#720969];
SQL []; Violation of PRIMARY KEY constraint 'PK__CONTENT___3214EC27FB627BCE'.
Cannot insert duplicate key in object 'dbo.CONTENT_LABEL'.
The duplicate key value is (720969).; nested exception is java.sql.SQLException:
Violation of PRIMARY KEY constraint 'PK__CONTENT___3214EC27FB627BCE'.
Cannot insert duplicate key in object 'dbo.CONTENT_LABEL'. The duplicate key value is (720969).
Back end is a SQL Server 2012.
Thx
G.