As in the directions (http://confluence.atlassian.com/display/JIRA/Integrating+JIRA+with+Apache#IntegratingJIRAwithApache-Enablemodproxyandmodproxyhttp) .... I have the following set up:
This is a 'stand-alone' install:
{atlassian.home}/jira/conf/server.xml
<Context path ="/JRA" ... >
{httpd.home}/conf/httpd.conf
<VirtualHost xxx.xxx.xxx.xxx:80>
...
ProxyPass /JRA http://localhost:8080/JRA
ProxyPassReverse /JRA http://localhost:8080
</VirtualHost>
This is on a RHEL 5 box. I'm using multiple IPs in my virtual host config (one is dedicated to JIRA .. going to add SSL later, butjust want to get the basic proxy part working first).
Everything works fine, can log in etc., but gadgets don't work. Nothing in the dashboard and get 'gadget directory failed to load' when I click to add gadget. I only have it configured to respond to a single URL and am using a dedicated IP for each vHost in apache. No 404's in apache except for favicon and /secure/useravatar?bla=blah ...
Any ideas?