Apparently this is related to a known but not fixed bug "Unable to create a Confluence Space when a default space logo is configured". If you turn off the default space logo, it fixes the problem.
First, double check if your server base URL is correctly set in Confluence admin > general configuration and make sure if is the same as you access Confluence.
I was having this problem and this solved it. Took way to long to figure out however.
muchas gracias
It looks like you're new here. Sign in or register to get started.