Hi,
We are using Confluence in DataCenter.
Every time when we stop and start Confluence server, there is a mismatch in build number between database and home directory.
We have to manually update the build number in confluence.cfg.xml file to start the Confluence.
Error: ERROR [Catalina-utility-1] [atlassian.confluence.setup.BootstrapApplicationStartupListener] checkConfigurationOnStartup Confluence cluster node will not start up because the build number in the database [8301] doesn't match either the application build number [8701] or the home directory build number [8701].
Please let us know why this issue is being occurred and how to resolve this.