升级方法
须藤./atlassian-confluence-7.13.0-x64.bin
Cannot start after upgrading
confluence.service - LSB: Atlassian Confluence
Loaded: loaded (/etc/init.d/confluence; generated)
Active: failed (Result: exit-code) since Wed 2021-09-29 03:19:54 UTC; 17min ago
Docs: man:systemd-sysv-generator(8)
Process: 27654 ExecStart=/etc/init.d/confluence start (code=exited, status=1/FAILURE)
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: ---------------------------------------------------------------------------
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: Existing PID file found during start.
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: Tomcat appears to still be running with PID 26719. Start aborted.
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: If the following process is not a Tomcat process, remove the PID file and try again:
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: UID PID PPID C STIME TTY TIME CMD
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: conflue+ 26719 1 5 03:01 ? 00:00:56 /opt/atlassian/confluence/jre//bin/java -Djava.util.logging.config.file=/opt/
Sep 29 03:19:54 ip-172-31-42-222 runuser[27671]: pam_unix(runuser:session): session closed for user confluence1
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: confluence.service: Control process exited, code=exited status=1
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: confluence.service: Failed with result 'exit-code'.
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: Failed to start LSB: Atlassian Confluence.
Also tried manual start
sudo /opt/atlassian/confluence/bin/start-confluence.sh -fg
systemctl status confluence.service
confluence.service - LSB: Atlassian Confluence
Loaded: loaded (/etc/init.d/confluence; generated)
Active: failed (Result: exit-code) since Wed 2021-09-29 03:19:54 UTC; 1h 12min ago
Docs: man:systemd-sysv-generator(8)
Process: 27654 ExecStart=/etc/init.d/confluence start (code=exited, status=1/FAILURE)
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: ---------------------------------------------------------------------------
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: Existing PID file found during start.
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: Tomcat appears to still be running with PID 26719. Start aborted.
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: If the following process is not a Tomcat process, remove the PID file and try again:
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: UID PID PPID C STIME TTY TIME CMD
Sep 29 03:19:54 ip-172-31-42-222 confluence[27654]: conflue+ 26719 1 5 03:01 ? 00:00:56 /opt/atlassian/confluence/jre//bin/java -Djava.util.logging.config.file=/opt/
Sep 29 03:19:54 ip-172-31-42-222 runuser[27671]: pam_unix(runuser:session): session closed for user confluence1
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: confluence.service: Control process exited, code=exited status=1
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: confluence.service: Failed with result 'exit-code'.
Sep 29 03:19:54 ip-172-31-42-222 systemd[1]: Failed to start LSB: Atlassian Confluence.