Hello!
I updated my Oralce linux and after it I got an empty confluence.cfg.xml file in /var/atlassian/application-data/confluence/
when I go to Confluence web page I see an error such as:
| fatal | BootstrapException: Unable to bootstrap application: Failed to parse config file: Error on line -1 of document : Premature end of file. Nested exception: Premature end of file. |
I tried to replace this file with such file in /var/atlassian/application-data/confluence/shared-home directory, but it didn't work and at the web page I saw error like:
| fatal | NullPointerException: |
Also I tried to update confluence with last bin file, but also got an error:
[Fatal Error] confluence.cfg.xml:1:1: Premature end of file.
Unfortunatelly i don't have a backup file. Could you give to me some advices how to recovery serviceability of my Confluence server, please.