We are running Jira Server 6.3.12. Everything was apparently running fine until a few days ago.
The plugins page found at http://<url>.com/plugins/servlet/upm returns an error of "Oops, you've found a dead link".
Under 'User Installed Add-ons', the 'Atlassian Universal Plugin Manager Plugin' is showing as disabled (version 2.22.24).
As per another post on this site, I deleted the two plugin cache folders and restarted but this did not resolve the issue.
Any other suggestions and resolutions would be very welcome as I can't find any other easy way of getting this plugin enabled.