Hello,
we have a Jira Software Instance that doesnt make use of boards and the ranking feature.
We are examining some issues with failing SQL statements and these problems always seem to be preceeded by this SQL failing (from the postgres log file):
2021-04-19 07:00:37.633 CEST [3323] jira@jiradb ERROR: canceling statement due to user request
2021-04-19 07:00:37.633 CEST [3323] jira@jiradb CONTEXT: while updating tuple (504,154) in relation "AO_60DB71_LEXORANK"
2021-04-19 07:00:37.633 CEST [3323] jira@jiradb STATEMENT: UPDATE public."AO_60DB71_LEXORANK" SET "LOCK_HASH" = $1, "LOCK_TIME" = $2 WHERE "ID" IN ($3, $4) AND ("LOCK_HASH" IS NULL OR "LOCK_TIME" < $5)
2021-04-19 07:00:37.679 CEST [3323] jira@jiradb ERROR: current transaction is aborted, commands ignored until end of transaction block
The docs state
"service status" will bet set to "Balancing disabled" when (among other things) "balancing has been explicitly suspended by Support or an administrator".
My questions:
- How can i disable balancing?
- How can i see when balancing takes place?
- Is there a way to disable the whole ranking system?
- Can maybe restrict balancing to certain hours?
Edit:
Im sure the cause is not in the rebalancing feature of Lexo Rank, its in what happens inside Jira Software when an issue is created and rank is applied to the new issue (even when a rebalance is not running)
I could also reproduce this for a case with only few issues being created.
Thanks in advance
Jens