Hi everyone
I have a problem with our old confluence v5 server currently due to corruption in the mysql innoDB where a prepared XA transaction will not rollback or commit. I have spent hours beating my head with every guide I can find. I can get access to the innoDB with restore mode set to 4. it shows no prepared transaction but when you try to go back to no restore mode it fails with a prepared transaction again (same id).
That said we do have a recent confluence backup which I want to be able to restore to a new server.
Being such an old version what is the best approach to restoring the backup to a new version of confluence? Install the old version, restore then update or just Install latest and then restore.
Thanks in advance