Here's the situation:
When a PDF file is uploaded to Confluence Server using using the 'Insert files and images' tool in edit mode, the normal outcome is a thumbnail preview of the PDF on the page.
However, this may fail using Confluence Server out of the box because of insufficient memory allocated to Java. Failure results in a placeholder being shown where normally one would see the PDF preview.
This post presumes that the memory allocation problem has already been solved. Now uploaded PDFs preview normally. However, a PDF that has previously failed to be processed for the preview will continue to be shown with the placeholder icon, even when it is removed from the page and reattached.
In testing, we've even gone so far as to restart the server after removing the file, changing the file name, and then attaching it to a different page. Still it appears with the placeholder icon first allocated to it when its thumbnail processing failed.
So, how does Confluence Server recognise the file is one that it has seen before, and how can thumbnail processing be forced? For example, is there a specific hook in the database that needs to be removed?