When a new elastic instance comes up it fails to start the elastic agent. I see the following error in the bamboo-elastic-agent.out log:
root@ip-172-31-17-228:/opt/bamboo-elastic-agent/bin# /etc/init.d/bamboo start
Starting bamboo
root@ip-172-31-17-228:/opt/bamboo-elastic-agent/bin# Starting Elastic Bamboo Agent...
2015-07-01 06:39:20,292 INFO [main] [S3Sync] Syncing from: bamboo-agent-release-eu-w1/5.10-OD-01-004/38e64b49d9dd5dda25c940a4d073a02981351da7/ to /opt/bamboo-elastic-agent
2015-07-01 06:39:20,594 INFO [main] [S3Utils] Syncing s3://bamboo-agent-release-eu-w1/5.10-OD-01-004/38e64b49d9dd5dda25c940a4d073a02981351da7/ to /opt/bamboo-elastic-agent
2015-07-01 06:39:20,594 INFO [main] [S3Utils] Fetching the list of remote objects...
Exception in thread "main" AmazonS3Exception: Status Code: 403, AWS Service: Amazon S3, AWS Request ID: 55ADF7C42A65EB83, AWS Error Code: AccessDenied, AWS Error Message: Access Denied, S3 Extended Request ID: Gwr6WB1yFSXVj8AMDwarJFNoUgcWJN0iCGdp1yaCQdRl2fAwLtIV8Ah61hP/A1vmkWWZknNxEXo=
at com.amazonaws.http.AmazonHttpClient.handleErrorResponse(AmazonHttpClient.java:644)
at com.amazonaws.http.AmazonHttpClient.executeHelper(AmazonHttpClient.java:338)
at com.amazonaws.http.AmazonHttpClient.execute(AmazonHttpClient.java:190)
. . .
We have a license for 5 remote agents. Now there is only 2 agents in running state, the 3 of them always in pending state. We have manually terminated these 3 this morning, but server starts new agents as there is queue and it will increase during the day.
Please advise! We are almost totally blocked.