Hi,
We are currently using JIRA 4.3.2 and would like to upgrade to the latest stable release 5.2. In order to test the upgrade, I followed the following steps which are all based on the articles on the atlassian site:
- backed up the current version data (zip file)
- installed the latest version on my test machine
- imported the data into the new version
Now, to complete the installation, I want to login to jira using an evaluation license but with my actual user. This is a valid user on our crowd server. But I cannot pass the wizard page 'Confirm New Installation'. It seems that my jira server is looking for the crowd on localhost:
*********************************************************************************
JIRA 5.2.11 build: 854 started. You can now access JIRA through your web browser.
*********************************************************************************
2013-04-30 15:39:43,297 localhost-startStop-1 ERROR [atlassian.jira.license.LicenseJohnsonEventRaiserImpl] The current license is too old (13/Apr/13) to run this version (5.2.11 - Mon Apr 15 00:00:00 EDT 2013) of JIRA.
2013-04-30 15:39:43,299 localhost-startStop-1 ERROR [atlassian.jira.upgrade.UpgradeLauncher] No upgrade is being performed due to detected inconsistencies. The current license is too old to install this version of JIRA (5.2.11)
2013-04-30 15:39:44,370 Modification Check:thread-1 INFO [atlassian.jira.startup.JiraStartupLogger]
___ Modifications ___________________________
Modified Files : jira-application.properties, seraph-config.xml
Removed Files : None
2013-04-30 15:39:44,521 localhost-startStop-1 INFO [ext.bamboo.service.PlanStatusUpdateServiceImpl] Job 'com.atlassian.jira.plugin.ext.bamboo.service.PlanStatusUpdateServiceImpl:job' scheduled to run every 60000ms
2013-04-30 15:39:44,752 localhost-startStop-1 INFO [jira.whatsnew.listeners.WhatsNewUpgradeFinishedListenerImpl] Enabling show-whats-new-flag for all users
2013-04-30 15:39:45,187 localhost-startStop-1 INFO [atlassian.jira.scheduler.JiraSchedulerLauncher] JIRA Scheduler not started: Johnson events detected.
30-Apr-2013 3:39:45 PM org.apache.catalina.startup.HostConfig start
SEVERE: Unable to create directory for deployment: /opt/atlassian/jira/conf/Catalina/localhost
30-Apr-2013 3:39:45 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8019"]
30-Apr-2013 3:39:45 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 24037 ms
2013-04-30 15:40:26,383 http-bio-8019-exec-5 ERROR anonymous 940x5x1 1k5jg5 127.0.0.1 /secure/ConfirmNewInstallationWithOldLicense.jspa [com.atlassian.scheduler.OfBizJobStore] The Quartz Job class 'com.pyxis.greenhopper.jira.customfields.GreenHopperRankingJob' cannot be loaded
2013-04-30 15:40:26,383 http-bio-8019-exec-5 ERROR anonymous 940x5x1 1k5jg5 127.0.0.1 /secure/ConfirmNewInstallationWithOldLicense.jspa [com.atlassian.scheduler.OfBizJobStore] The Quartz Job configuration for 'GreenHopperIndexes' is invalid! This can be caused by Plugin JARS no longer being available on the class path.
2013-04-30 15:40:26,383 http-bio-8019-exec-5 ERROR anonymous 940x5x1 1k5jg5 127.0.0.1 /secure/ConfirmNewInstallationWithOldLicense.jspa [com.atlassian.scheduler.OfBizJobStore] A NoOp Job class has been returned and hence 'GreenHopperIndexes' will not do anything until fixed.
2013-04-30 15:40:26,436 http-bio-8019-exec-5 ERROR anonymous 940x5x1 1k5jg5 127.0.0.1 /secure/ConfirmNewInstallationWithOldLicense.jspa [crowd.manager.application.ApplicationServiceGeneric] Directory 'Remote Crowd Directory' is not functional during authentication of 'rhaeri'. Skipped.
2013-04-30 15:40:26,448 http-bio-8019-exec-5 ERROR [500ErrorPage.jsp] Exception caught in 500 page The following URL does not specify a valid Crowd User Management REST service: http://localhost/crowd/rest/usermanagement/1/authentication?username=rhaeri
com.atlassian.crowd.exception.runtime.OperationFailedException: The following URL does not specify a valid Crowd User Management REST service: http://localhost/crowd/rest/usermanagement/1/authentication?username=rhaeri
at com.atlassian.crowd.embedded.core.CrowdServiceImpl.convertOperationFailedException(CrowdServiceImpl.java:855)
at com.atlassian.crowd.embedded.core.CrowdServiceImpl.authenticate(CrowdServiceImpl.java:79)
at com.atlassian.crowd.embedded.core.DelegatingCrowdService.authenticate(DelegatingCrowdService.java:35)
I tried to follow the advice in this article: http://goo.gl/K6lsP by creating a 'crowd.properties' 'seraph-config.xml'. In crowd.properties I changed the 'crowd.base.url' to point to out crowd server. No luck!
I want to make sure that I can upgrade safely from 4.3.2 to 5.2 on a test machine before going ahead and do it on the main server.
Any help is greatly appreciated.