I am trying to assist with a Jira upgrade from 6.3 to 7.0
In both cases, when trying to upgrade the UPM it completely fails. The plugin won't enable, I get the pirate skull & crossbones, the page 404s, Garfield comes and takes my lasagna... OK that last part didn't happen. Yet.
Even if I remove ALL plugins, start Jira, and attempt to upgrade the UPM I see messages like those below. Anyone have an idea?
2020-12-17 09:30:37,309 UpmAsynchronousTaskManager:thread-3 INFO (user ID redacted) 570x207x1 47w0nf (IP redacted) /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed
2020-12-17 09:30:37,677 UpmAsynchronousTaskManager:thread-3 INFO (user ID redacted) 570x207x1 47w0nf (IP redacted) /rest/plugins/1.0/ [c.a.plugin.util.WaitUntil] Plugins that have yet to be enabled: (1): [com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin], 60 seconds remaining
2020-12-17 09:30:39,732 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed
2020-12-17 09:30:40,926 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin': []. Disabling...
2020-12-17 09:30:40,926 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.manager.DefaultPluginManager] Found mandatory, optional and dynamically dependent plugins to re-enable after plugin upgrade 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin': []. Enabling...
2020-12-17 09:30:40,943 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' from version '2.20.3' to version '2.22.24'
2020-12-17 09:30:40,951 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.manager.DefaultPluginManager] Disabling com.atlassian.upm.atlassian-universal-plugin-manager-plugin
2020-12-17 09:30:41,170 pool-15-thread-1 DEBUG (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] onPluginDisabledEvent removing delegate for [com.atlassian.upm.atlassian-universal-plugin-manager-plugin]
2020-12-17 09:30:41,203 pool-15-thread-1 INFO (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] Removed plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
2020-12-17 09:30:41,241 pool-15-thread-1 ERROR (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.p.osgi.factory.OsgiPluginInstalledHelper] Cannot determine required plugins, cannot resolve bundle 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
2020-12-17 09:30:41,243 pool-15-thread-1 ERROR (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.p.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Unresolved constraint in bundle com.atlassian.upm.atlassian-universal-plugin-manager-plugin [167]: Unable to resolve 167.0: missing requirement [167.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.jira.config.properties)(version>=7.9.0)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN
2020-12-17 09:30:41,245 pool-15-thread-1 WARN (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.impl.AbstractPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
2020-12-17 09:30:41,246 pool-15-thread-1 WARN (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.plugin.impl.AbstractPlugin] Because of this exception
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
...
2020-12-17 09:31:41,736 pool-15-thread-1 WARN (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.upm.selfupdate.UpdateController] After updating UPM, the plugin "Atlas
sian Universal Plugin Manager Plugin" became disabled. This may be due to a bug present in older product versions (UPM-3116). UPM failed to re-enable the plugin.
2020-12-17 09:31:42,236 pool-15-thread-1 WARN (user ID redacted) 570x251x1 47w0nf (IP redacted) /rest/plugins/self-update/1.0/ [c.a.upm.selfupdate.UpdateController] Received HTTP error 404 from UPM completion resource