Hi Team,
I installed confluence and I'm not able to run the service. I'm getting this error after running startup.sh and also /var/atlassian/application-data/confluence is empty. Attached error screenshot. Please help me resolve this issue.
@Bhagya k
Does the file /opt/tomcat/apache-tomcat-8.5.46/bin/setclasspath.sh exist?If existing, are the rights set correctly?
Hi @repi , Thanks for your response.
file does not exist.
The startup.sh is also not the start file for the confluence.For manual start or as a system service, confluence must be started with start-confluence.sh.As a service with systemd, I solved it like this:
[Unit] Description=Atlassian Confluence mit Postgresql (Wiki) After=syslog.target network.target [Service] Type=forking User=confluence #Environment="JAVA_HOME=/usr/lib/jvm/jdk1.8.0_191" #Environment="JRE=/usr/lib/jvm/jdk1.8.0_191/jre" ExecStart=/data/atlassian_ps/confluence/bin/start-confluence.sh ExecStop=/data/atlassian_ps/confluence/bin/stop-confluence.sh [Install] WantedBy=multi-user.target
The environment settings are commented out. Can be set, if working with different Java software, deviating from the system standard
It looks like you're new here. Sign in or register to get started.