After a routine "dnf update" on a CentOS8 machine, Jira Core v8.6.0 starts up without any errors, but refuses to serve any pages.
The end user is told "Sorry, we had some technical problems during your last operation".
The underlying Java stacktrace (summarised is as follows):
com.opensymphony.module.propertyset.PropertyImplementationException: Unable to load values for CacheKey[entityName=ApplicationUser,entityId=10083]
Caused by: com.atlassian.cache.CacheException: com.atlassian.jira.exception.DataAccessException: org.postgresql.util.PSQLException: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
Caused by: com.atlassian.jira.exception.DataAccessException: org.postgresql.util.PSQLException: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
Caused by: org.postgresql.util.PSQLException: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
Caused by: java.net.ConnectException: Connection refused (Connection refused)
Obviously, this is telling me that the database is not accepting connections on localhost port 5432.
Except the database is accepting connections on localhost port 5432.
[jira@jira ~]$ telnet 127.0.0.1 5432
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
^]quit
telnet> quit
Connection closed.
[jira@jira ~]$ telnet ::1 5432
Trying ::1...
Connected to ::1.
Escape character is '^]'.
^]quit
telnet> quit
Connection closed.
[jira@jira ~]$ psql -d "postgresql://localhost:5432" jira
Password for user jira:
psql (10.6)
Type "help" for help.
jira=> \d
List of relations
Schema | Name | Type | Owner
--------+-------------------------------------------+----------+-------
public | AO_0201F0_KB_HELPFUL_AGGR | table | jira
public | AO_0201F0_KB_HELPFUL_AGGR_ID_seq | sequence | jira
public | AO_0201F0_KB_VIEW_AGGR | table | jira
public | AO_0201F0_KB_VIEW_AGGR_ID_seq | sequence | jira
public | AO_0201F0_STATS_EVENT | table | jira
public | AO_0201F0_STATS_EVENT_ID_seq | sequence | jira
For obvious reasons I am very stuck.
Anyone seen weirdness like this happen before?