When starting up Confluence 7.2.1 on Windows Server 2019 using MySQL 5.7, the web page displays "Confluence had problems starting up" followed by:
"Unable to start up Confluence. Fatal error during startup sequence: confluence.lifecycle.core:mananagedjobs (Start and stop the Managed Scheduled Jobs)"
"could not extract ResultSet; SQL [n/a]; nested exception is org.hibernate.exception.SQLGrammarException: could not extract ResultSet"
I had to shutdown the server hosting Confluence over the weekend due to a scheduled power outage, I received the above errors when trying to start Confluence back up on Monday morning. No other changes have been made to the server or to Confluence. My Jira Core installation is functioning fine.
Also, not sure this is applicable, but when starting confluence from the command prompt I see this:
"---------------------------------------------------------------------------"
"Using Java:
\jre1.8.0_231\bin\java.exe"
Error: Unable to access jarfile C:\Program
Error: Unable to access jarfile C:\Program
"---------------------------------------------------------------------------"
From the atlassian-confluence.log file:
2020-07-11 20:26:59,061 ERROR [Caesium-1-2] [engine.jdbc.spi.SqlExceptionHelper] logExceptions Table 'confluence.scheduler_run_details' doesn't exist
2020-07-11 20:26:59,062 ERROR [Caesium-1-2] [org.hibernate.internal.ExceptionMapperStandardImpl] mapManagedFlushFailure HHH000346: Error during managed flush [org.hibernate.exception.SQLGrammarException: could not execute statement]
2020-07-11 20:26:59,062 WARN [Caesium-1-2] [confluence.impl.hibernate.ConfluenceHibernateTransactionManager] doCommit Commit failed. Rolling back. Error: Hibernate operation: could not execute statement; bad SQL grammar []; nested exception is com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'confluence.scheduler_run_details' doesn't exist
2020-07-11 20:26:59,062 WARN [Caesium-1-2] [confluence.impl.hibernate.ConfluenceHibernateTransactionManager] doRollback Performing rollback.
Any assistance pointing me in the right direction to get this back up and running is greatly appreciated!