We are using Jira 4.2.2 with crowd. Crowd uses a filter when connecting to our Active Directory server. I had modified that AD filter to include some people that were excluded from the original one. I tried to check with Jira that these users were indeed now included when I was prompted for the jira-admin password. It failed to authenticate jira-admin. Other users were nevertheless still able to be authenticated.
A little later, Jira still failed to authenticate jira-admin, but instead of blankly refusing access, it asked for a capcha. And it keeps asking for a capcha, and access is never achieved. And then the other users were also being refused access, and Jira is currently unusable.