Confluence (on-prem) Server - 7.2.0
Cloud Migration Assistant for Confluence - 3.0.2
Plugin installs OK.
Plugin fails to enable.
Cause:
org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getInitialState' in class com.atlassian.migration.agent.web.AppAction threw exception com.atlassian.util.concurrent.LazyReference$InitializationException: javax.persistence.PersistenceException: Failed to update database schema at /templates/app.vm[line 21, column 44]
at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:228)
caused by: com.atlassian.util.concurrent.LazyReference$InitializationException: javax.persistence.PersistenceException: Failed to update database schema
at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:149)
caused by: javax.persistence.PersistenceException: Failed to update database schema
at com.atlassian.migration.agent.store.jpa.impl.LiquibaseSchemaUpgrader.upgrade(LiquibaseSchemaUpgrader.java:35)
caused by: liquibase.exception.LockException: Could not acquire change log lock. Currently locked by 262e58e7ef0d (172.17.0.3) since 4/28/20 11:54 AM
at liquibase.lockservice.StandardLockService.waitForLock(StandardLockService.java:230)