Fresh bitbucket installation is working on http (7990).
When we try to switch to the https (443 or 8443) there is error on bitbucket starting.
Some details:
Bitbucket v6.8.1
Bitbucket keystore
---------------------------------
Keystore type: PKCS12
Keystore provider: SUN
Your keystore contains 1 entry
tomcat, Mar 1, 2020, PrivateKeyEntry,
echo $JAVA_HOME
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.232.b09-0.el8_0.x86_64
bitbucket.properties
-------------------------------
server.port=443
server.scheme=https
server.ssl.enabled=true
server.ssl.key-store-type=pkcs12
server.ssl.key-store=/var/atlassian/application-data/bitbucket/shared/config/ssl-keystore/bitbucket.jks
Bitbucket log:
------------------
426 ERROR [main] o.apache.catalina.util.LifecycleBase Failed to start component [Connector[HTTP/1.1-443]
Caused by: java.net.SocketException: Permission denied
The Tomcat connector configured to listen on port 443 failed to start. The port may already be in use or the connector may be misconfigured.
Action:
Verify the connector's configuration, identify and stop any process that's listening on port 443, or configure this application to listen on another port.
Network:
--------------
netstat -tupan | grep 443
returns empty list
The same is with 8443 port.