Hi,
I have jira on premises licence. But from last week i am unable to login now when i try to find it looks something has change in database we are using postgresql with it and below are the error.
1. jira log:- Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:SELECT ID, LICENSE_ROLE_NAME, GROUP_ID, PRIMARY_GROUP FROM public.licenserolesgroup WHERE LICENSE_ROLE_NAME=? (ERROR: column "id" does not exist
2. pg dump has error:- pg_dump: invalid column numbering in table "label"
3. also find that column id has changed inside database
jiradb=# \d public.licenserolesgroup
Table "public.licenserolesgroup"
Column | Type | Modifiers
-------------------+------------------------+-----------
iD | numeric(18,0) | not null
license_role_name | character varying(255) |
group_id | character varying(255) |
primary_group | character(1) |
Indexes:
"pk_licenserolesgroup" PRIMARY KEY, btree ("iD")
"licenserolegroup_index" UNIQUE, btree (license_role_name, group_id)