Backup was working for some time. But it started failing after we migrated more repositories to stash. The error we received is:
WARN [threadpool:thread-995154] admin 1320x3126501x1 1utuvpt 172.16.100.94,0:0:0:0:0:0:0:1 "POST /mvc/admin/backups HTTP/1.1" c.a.s.i.m.LatchAndDrainDatabaseStep The DataSource could not be drained; some database connections are still open. Aborting migration...
WARN [threadpool:thread-995154] admin 1320x3126501x1 1utuvpt 172.16.100.94,0:0:0:0:0:0:0:1 "POST /mvc/admin/backups HTTP/1.1" c.a.s.i.m.DefaultMaintenanceTaskMonitor BACKUP maintenance has failed (Cause: BackupException: A backup file could not be created.)
...
Caused by: com.atlassian.stash.internal.migration.MigrationException: One or more database connections were not closed within the allotted timeout. To prevent corruption due to inconsistent state, the migration has been aborted. Please try your migration again when the system is under less load.
The time out happened within 1min when it tried to drain the data source. Is there a way to increase the timeout? I don't see such an option in the backup client config file.
the external database we are using is mysql.
Thanks.