We have a JIRA instance where we have enabled SSO using this particular implementation: https://github.com/chauth/jira_http_authenticator
This works fine for our needs in our environment. When we finally upgraded to a version that supported the Jira mobile app, we noticed a particular behavior. When the app is first started and the instance added, it initially would not connect and determine that the instance was there because the initial request was being forwarded to the SSO page.
The app was hitting the url: [baseurl]/server-info to look for something in particular. If we exempted this url from SSO, the app will then prompt the user for the username and password from the SSO page and log in successfully.
This works correctly in the app with no issues for a certain period of time and then the session will time out and give various errors reporting "Unable to connect" and similar. Going into the settings in the app, logging out, and then logging back in will prompt for the SSO page again and then work for the same period of time.
Is there something that needs to be configured in the SSO configuration so the app knows to go back to the SSO page when the session expires?