I have Confluence 4.1 installed and running with an external Oracle db. I am trying to upgrade and have been running into roadblock after roadblock. I decided to install 4.1 on a seperate server and try to upgrade it to make sure this works before i touch my production version. I tried to make the copy of my production version as suggested in the documentation and that did not work so i figured id just try and install and upgrade an evaluation version. I keep running into these errors when I first startup confluence after i have made the correct adjustments to the server.xml and the confluence-init.properties files along with placing the correct ojdbc5jar in the lib directory. These errors appear on the first startup of confluence:
this is from the atlassian-confluence.log....
2012-08-21 08:10:57,214 ERROR [main] [atlassian.confluence.upgrade.UpgradeLauncherServletContextListener] contextInitialized 1: Cannot update schema
2012-08-21 08:10:57,215 WARN [main] [atlassian.confluence.plugin.PluginFrameworkContextListener] contextInitialized Not starting full plugin system due to upgrade or licensing errors
This is from the catalina.out...
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
Aug 21, 2012 8:09:48 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090
Aug 21, 2012 8:09:48 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 407 ms
Aug 21, 2012 8:09:48 AM org.apache.catalina.core.StandardService start
INFO: Starting service Tomcat-Standalone
Aug 21, 2012 8:09:48 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.32
2012-08-21 08:09:49,998 INFO [main] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 4.2.13 (build #3296)
create table CONTENTPROPERTIES (PROPERTYID number(19,0) not null, PROPERTYNAME varchar2(255) not null, STRINGVAL varchar2(255), LONGVAL number(19,0), DATEVAL date, CONTENTID number(19,0), primary key (PROPERTYID))
alter table CONTENT_LABEL add ATTACHMENTID number(19,0)
alter table CONTENT_LABEL add PAGETEMPLATEID number(19,0)
alter table CONTENT_LABEL add LABELABLEID number(19,0)
alter table CONTENT_LABEL add LABELABLETYPE varchar2(255)
create table LIKES (ID number(19,0) not null, CONTENTID number(19,0) not null, USERNAME varchar2(255) not null, CREATIONDATE date not null, primary key (ID))
alter table CONTENT add PLUGINKEY varchar2(255)
alter table CONTENT add PLUGINVER varchar2(255)
alter table CONTENTPROPERTIES add constraint FK984C5E4C8DD41734 foreign key (CONTENTID) references CONTENT
create index content_prop_str_idx on CONTENTPROPERTIES (STRINGVAL)
create index content_prop_long_idx on CONTENTPROPERTIES (LONGVAL)
create index content_prop_name_idx on CONTENTPROPERTIES (PROPERTYNAME)
create index content_prop_date_idx on CONTENTPROPERTIES (DATEVAL)
create index attch_data_idx on ATTACHMENTDATA (ATTACHMENTID)
Aug 21, 2012 8:10:59 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090
Aug 21, 2012 8:10:59 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 70832 ms
Im wondering if the issue is that i cant upgrade and evaluation version.
Im seeing this in the atlassian-confluence.log...
2012-08-21 08:10:57,178 ERROR [main] [atlassian.confluence.upgrade.UpgradeLauncherServletContextListener] contextInitialized Upgrade failed, application will not start: com.atlassian.config.ConfigurationException: Cannot update schema
i know this is not a permissions issue with my database.