During installation of Confluence 7.2, the server hangs during the setup of the database schema and ends up with a stuck thread. Once the stuck thread recovers and I refresh the page, the batch.css file fails with a 500 error. If I go to the path of the batch.css file, the page says that the container was not started. There are two batch.css files that this happens on: one for the generic style and the other for the setup style.
The server I am running on has 4gb of ram and 3 cpu cores. I've attached the log for Confluence and the stacktrace on the batch.css file.
Confluence log
batch.css stacktrace