I'm using atlassian/ftp-deploy:0.2.2 to sync code with production server. The problem is that on every pipeline run and on every step Bitbucket is showing this:
<span>0.2.2: Pulling from bitbucketpipelines/ftp-deploy</span><span>Unable to find image 'bitbucketpipelines/ftp-deploy:0.2.2' locally</span>
Is he unable to cache for some reason? Below is the bitbucket-pipelines.yml, I know it can be improved but is there any way to let Bitbucket cache the image locally so i will not waste time on download and extraction?
image: composer:latest
pipelines:
default:
- step:
name: Deploy project
caches:
- docker
script:
- echo "Deploying project to server..."
- rm .env
- rm -R .git
- pipe: atlassian/ftp-deploy:0.2.2
variables:
USER: $DEPLOY_USER
SERVER: $DEPLOY_SERVER
PASSWORD: $DEPLOY_PASSWORD
REMOTE_PATH: $DEPLOY_REMOTE_PATH
- step:
name: Notify system
deployment: Production
caches:
- docker
script:
- echo "Leaving update mark..."
- mkdir $DEPLOY_NOTIFY_DIR
- touch $DEPLOY_NOTIFY_DIR/.keep
- pipe: atlassian/ftp-deploy:0.2.2
variables:
USER: $DEPLOY_USER
SERVER: $DEPLOY_SERVER
PASSWORD: $DEPLOY_PASSWORD
LOCAL_PATH: $DEPLOY_NOTIFY_DIR
REMOTE_PATH: $DEPLOY_REMOTE_PATH/$DEPLOY_NOTIFY_DIR