Hi I am having some trouble with making a application link between my jira (Windows Server 2016) and my Bitbucket (Linux 18.04.02) with an Nginx proxy in front that does HTTP redirect and SSL.
Then I try to make the link it get the following error:
"No response was received from the URL you entered - it may not be valid. Please fix the URL below, if needed, and click Continue."
The URL is correct. Both servers are able to ping each other. In the Atlassian-bitbucket.log file it comes with this error: "Caused by: org.apache.http.conn.ConnectTimeoutException: Connect to jira.domain.com:443 [jira.domain.com/localip] failed: Read timed out"
On the Jira server I get the following:
" Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target"
Both servers use the same CA certificate which works fine. What am I missing here?