Hello. How can I add to startup service Confluence on CentOS 7? After restarting the server, the service does not start.
P.S. This solution is not work
Hello there,
Welcome to Atlassian Community! It's nice to have you.
To run Confluence as a service on Linux, you must use sudo to run the installer to be able to install Confluence as a service. The installer will create a dedicated user account, confluence, that will run the service.
sudo
confluence
Can you confirm that you used sudo to run the installer? Are you getting any error messages when the service tries to start?
Regards,
Shannon
I tried to run this script, but I get an error:
[root@confluence user]# su - root[root@confluence ~]# cd /opt/atlassian/confluence/bin/[root@confluence bin]# sudo sh install_linux_service.shinstalling Confluence as a servicewhich: no update-rc.d in (/sbin:/bin:/usr/sbin:/usr/bin)ln: failed to create symbolic link «/etc/rc0.d/K95confluence1»: File existsln: failed to create symbolic link «/etc/rc1.d/K95confluence1»: File existsln: failed to create symbolic link «/etc/rc2.d/S95confluence1»: File existsln: failed to create symbolic link «/etc/rc3.d/S95confluence1»: File existsln: failed to create symbolic link «/etc/rc4.d/S95confluence1»: File existsln: failed to create symbolic link «/etc/rc5.d/S95confluence1»: File existsln: failed to create symbolic link «/etc/rc6.d/K95confluence1»: File exists[root@confluence bin]#
I tried to create a file:/lib/systemd/system/confluence.service
with content:
[Unit]Description=ConfluenceAfter=network.target[Service]Type=forkingUser=confluencePIDFile=/opt/atlassian/confluence/work/catalina.pidExecStart=/opt/atlassian/confluence/bin/start-confluence.shExecStop=/opt/atlassian/confluence/bin/stop-confluence.shTimeoutSec=200LimitNOFILE=4096LimitNPROC=4096
[Install]WantedBy=multi-user.target
[root@confluence system]# systemctl daemon-reload
[root@confluence system]# systemctl enable confluence.serviceFailed to execute operation: File exists
[root@confluence system]# systemctl start confluence.serviceJob for confluence.service failed because the control process exited with error code. See "systemctl status confluence.service" and "journalctl -xe" for details.
[root@confluence system]# systemctl status confluence.service● confluence.service - ConfluenceLoaded: loaded (/etc/systemd/system/confluence.service; enabled; vendor preset: disabled)Active: failed (Result: exit-code) since Вт 2019-10-15 04:36:46 MSK; 2s agoProcess: 1498 ExecStart=/opt/atlassian/confluence/bin/start-confluence.sh (code=exited, status=1/FAILURE)
окт 15 04:36:46 confluence.loc systemd[1]: Starting Confluence...окт 15 04:36:46 confluence.loc start-confluence.sh[1498]: To run Confluence in the foreground, start the server with start-confluence.sh -fgокт 15 04:36:46 confluence.loc systemd[1]: confluence.service: control process exited, code=exited status=1окт 15 04:36:46 confluence.loc systemd[1]: Failed to start Confluence.окт 15 04:36:46 confluence.loc systemd[1]: Unit confluence.service entered failed state.окт 15 04:36:46 confluence.loc systemd[1]: confluence.service failed.[root@confluence system]#
It looks like you're new here. Sign in or register to get started.