Dear All,
Greeting!
We are trying to configure https ssl in our Cent OS 7 server but are failing to configure it. Our server is hosted in Azure. We tried with different but is failing. Any help will be highly appreciated.
Thank in Advance.
Best Regards,
Bikash
Hi All,
I did the configuration as per https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html?_ga=2.162524986.76426454.1569160471-1593542541.1565828118#RunningConfluenceOverSSLorHTTPS-serverconfig.
Please find my server.xml file
<Connector port="8443" maxHttpHeaderSize="8192"maxThreads="150" minSpareThreads="25"protocol="org.apache.coyote.http11.Http11Nio2Protocol"enableLookups="false" disableUploadTimeout="true"acceptCount="100" scheme="https" secure="true"clientAuth="false" sslProtocol="TLS" sslEnabledProtocols="TLS" SSLEnabled="true"URIEncoding="UTF-8" keystorePass="Password" keystoreFile="/home/confluence/.keystore"/>
My catalina.out output
24-Sep-2019 16:30:51.637 SEVERE [Catalina-utility-4] org.apache.catalina.loader.WebappClassLoaderBase.checkThreadLocalMapForLeaks The web application [ROOT] created a ThreadLocal with key of type [com.github.kristofa.brave.ThreadLocalServerAndClientSpanState$1] (value [com.github.kristofa.brave.ThreadLocalServerAndClientSpanState$1@1380d4a7]) and a value of type [com.github.kristofa.brave.AutoValue_ServerSpan] (value [ServerSpan{span=null, sample=null}]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.24-Sep-2019 16:30:51.654 INFO [main] org.apache.coyote.AbstractProtocol.stop Stopping ProtocolHandler ["http-nio-8090"]24-Sep-2019 16:30:51.660 INFO [main] org.apache.coyote.AbstractProtocol.destroy Destroying ProtocolHandler ["http-nio-8090"]24-Sep-2019 16:30:51.662 INFO [main] org.apache.coyote.AbstractProtocol.stop Stopping ProtocolHandler ["https-jsse-nio2-8443"]24-Sep-2019 16:30:51.662 INFO [main] org.apache.coyote.AbstractProtocol.destroy Destroying ProtocolHandler ["https-jsse-nio2-8443"]24-Sep-2019 16:31:04.021 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server] failed to set property [debug] to [0]24-Sep-2019 16:31:04.101 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'debug' to '0' did not find a matching property.24-Sep-2019 16:31:04.141 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine] failed to set property [debug] to [0]24-Sep-2019 16:31:04.147 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host] failed to set property [debug] to [0]24-Sep-2019 16:31:04.189 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host/Context] failed to set property [debug] to [0]24-Sep-2019 16:31:04.210 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host/Context] failed to set property [debug] to [0]24-Sep-2019 16:31:04.544 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-8090"]24-Sep-2019 16:31:04.574 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["https-jsse-nio2-8443"]24-Sep-2019 16:31:09.846 WARNING [main] org.apache.tomcat.util.net.Nio2Endpoint.shutdownExecutor The executor associated with thread pool [https-jsse-nio2-8443] has not fully shutdown. Some application threads may still be running.24-Sep-2019 16:31:09.848 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to initialize component [Connector[org.apache.coyote.http11.Http11Nio2Protocol-8443]]org.apache.catalina.LifecycleException: Protocol handler initialization failedat org.apache.catalina.connector.Connector.initInternal(Connector.java:983)at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)at org.apache.catalina.core.StandardService.initInternal(StandardService.java:533)at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:1059)at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)at org.apache.catalina.startup.Catalina.load(Catalina.java:584)at org.apache.catalina.startup.Catalina.load(Catalina.java:607)at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)at java.lang.reflect.Method.invoke(Method.java:498)at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:304)at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:474)Caused by: java.lang.IllegalArgumentException: None of the [protocols] specified are supported by the SSL engine : [[TLS]]at org.apache.tomcat.util.net.SSLUtilBase.getEnabled(SSLUtilBase.java:151)at org.apache.tomcat.util.net.SSLUtilBase.<init>(SSLUtilBase.java:109)at org.apache.tomcat.util.net.jsse.JSSEUtil.<init>(JSSEUtil.java:113)at org.apache.tomcat.util.net.jsse.JSSEUtil.<init>(JSSEUtil.java:108)at org.apache.tomcat.util.net.jsse.JSSEImplementation.getSSLUtil(JSSEImplementation.java:50)at org.apache.tomcat.util.net.AbstractJsseEndpoint.createSSLContext(AbstractJsseEndpoint.java:88)at org.apache.tomcat.util.net.AbstractJsseEndpoint.initialiseSsl(AbstractJsseEndpoint.java:71)at org.apache.tomcat.util.net.Nio2Endpoint.bind(Nio2Endpoint.java:142)at org.apache.tomcat.util.net.AbstractEndpoint.bindWithCleanup(AbstractEndpoint.java:1124)at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:1137)at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:574)at org.apache.coyote.http11.AbstractHttp11Protocol.init(AbstractHttp11Protocol.java:74)at org.apache.catalina.connector.Connector.initInternal(Connector.java:980)... 13 more24-Sep-2019 16:31:09.850 INFO [main] org.apache.catalina.startup.Catalina.load Server initialization in [5,919] milliseconds24-Sep-2019 16:31:09.859 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service [Tomcat-Standalone]24-Sep-2019 16:31:09.860 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet engine: [Apache Tomcat/9.0.22]SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".SLF4J: Defaulting to no-operation (NOP) logger implementationSLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.24-Sep-2019 16:31:12.254 INFO [Catalina-utility-2] org.apache.catalina.core.ApplicationContext.log 1 Spring WebApplicationInitializers detected on classpath24-Sep-2019 16:31:12.478 INFO [Catalina-utility-2] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.24-Sep-2019 16:31:12.867 INFO [Catalina-utility-2] org.apache.catalina.core.ApplicationContext.log Initializing Spring DispatcherServlet 'dispatcher'2019-09-24 16:31:13,894 INFO [Catalina-utility-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 7.0.1 [build 8202 based on commit hash 6ec4be8a9be53dc4390b2cd3f9a4c5731ee93a77] - synchrony version 3.1.0-master-8becbfc824-Sep-2019 16:33:29.772 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8090"]24-Sep-2019 16:33:29.997 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in [140,146] milliseconds24-Sep-2019 16:33:33.015 INFO [http-nio-8090-exec-10] com.sun.jersey.server.impl.application.WebApplicationImpl._initiate Initiating Jersey application, version 'Jersey: 1.19.4 05/24/2017 03:20 PM'24-Sep-2019 16:33:54.958 INFO [http-nio-8090-exec-9] com.sun.jersey.server.impl.application.WebApplicationImpl._initiate Initiating Jersey application, version 'Jersey: 1.19.4 05/24/2017 03:20 PM'
Hey, did you find any solution to this. am facing a similar issue
It looks like you're new here. Sign in or register to get started.