Jira has a /status that can be used as an health check for load balancer ect.
So it would respond with:
{"state":"FIRST_RUN"}when healthy.
But. while preparing the database at the setup step, it simply doesn't respond. Nothing does.
We get:
Service Unavailable
Also, when applying the license during the setup, we get the same (or lack thereof).
This basically make it useless for a health check.
Is this done intentionally by design ?
If we look at the documentation, a 404 indicates "Application failed to start up in an unexpected way (the web application failed to deploy)", yet this is not the case of setting up a database or license.
Are there any other way to check the health of Jira ?