Dear sirs,
after migrating our Confluence installation to a fresh new VPS (only dumped and restored the MySQL database) i get a spring error with the following cause:
com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.IllegalStateException: Spring Application context has not been set
Caused by: java.lang.IllegalStateException: Spring Application context has not been set
I already have found the following page:https://confluence.atlassian.com/confkb/confluence-does-not-start-due-to-spring-application-context-has-not-been-set-218278311.html
but followed its suggestions with no luck.Brgrds<Nick
Hello Nick,
Thank you for contacting us regarding this. That is the correct article, as the error tends to be caused by a configuration issue.
My recommendation would be to re-do the migration using the recommended migration method so we can be sure that there's not a configuration error causing the message.
See Migrating to Another Database for instructions on how to do that.
In short, you want to set up a fresh Confluence installation and migrate using your Confluence XML backup.
Let me know if you have any trouble with that.
Regards,
Shannon
It looks like you're new here. Sign in or register to get started.