Friends, help set up JIRA through nginx.
I configured everything according to the instructions, but still gives a 502 error
Two things,
Also, please check your Jira and Nginx log files. It will give you some more information.
Issue was due to SELinux.
Solution:
<span>setsebool </span><span>-</span><span>P httpd_can_network_connect </span><span>1</span>
1) Yes. This's my nginx conf:
server {listen 80;server_name kzlapjiraprod02;access_log /var/log/nginx/access.log main;error_log /var/log/nginx/error.log;
location / {client_max_body_size 100m;proxy_set_header X-Forwarded-Host $host;proxy_set_header X-Forwarded-Server $host;proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;proxy_pass http://localhost:8080;}}
2) No. How can I do it?
On point number two you can value of 'keepalive_timeout'
Apart from this check '/var/log/nginx/error.log' file, similar configuration works fine on my instance.
Thank you!
I checked for errors in logs and issue was in "Permission denied".
This command helped me to solved my issue
Nice catch @Aziz Ushurbakiyev
It looks like you're new here. Sign in or register to get started.