Hi! i was about to upgrade my 7.13.1 to the latest 8.3.1 Linux version. I ran into some issues during import, and probably(?) because of that some of the data is not working so i went back to old version until we get this solved.
My first attempt to upgrade failed because of the charset, so i made a new DB, and the restored the XML backup i had.
The error i see in SQL log was:
< 2019-08-13 15:31:34.123 EEST >ERROR: duplicate key value violates unique constraint "AO_575BF5_DEV_SUMMARY_pkey"
< 2019-08-13 15:31:34.123 EEST >DETAIL: Key ("ID")=(1) already exists.
< 2019-08-13 15:31:34.123 EEST >STATEMENT: INSERT INTO public."AO_575BF5_DEV_SUMMARY" ("CREATED", "ID", "ISSUE_ID", "JSON", "PROVIDER_SOURCE_ID", "UPDATED") VALUES ($1, $2, $3, $4, $5, $6)
and in GUI all i got was this:
There was a problem restoring ActiveObjects data for the plugin Atlassian Jira - Plugins - Development Integration Plugin(com.atlassian.jira.plugins.jira-development-integration-plugin) #5.5.0 plugin. Importing table AO_575BF5_DEV_SUMMARY failed. Please check the log for details.
Other issues after this was that my Scrum board didn't allow me to end the running sprint (could not find entity of type interface com.atlassian.greenhopper.service.sprint.SprintAO with key 157), so i couldn't start a new one either, and some other errors as well which i didn't document properly 
Any ideas?