Hi - We have been having consistent issues when building our on-prem Jira Service Desk server, and performing a backup restore.
We have tried several days worth of instances of the Jira performed backup, as well as a manual backup, and continue to run into the same issues.
A little history: We had inadvertantly installed SQL Server 2017 Enterprise. Se we needed to uninstall, and install the Standard version. Upon completion of the SQL installation, we performed the creation of the DB to be used, and then started Jira to then restore the backup data.
All seemed to work - until the sidebar wouldn't load. We then had to enable the Dark Feature: com.atlassian.jira.config.BIG_PIPE_KILLSWITCH.
Then we noticed that some site features were missing, and we were unable to access or configure anything under Request Types. Doing so gives us the error: "jira Snap! You can't view this page You need to be a Service Desk Agent to access this page. Contact your administrator if you need access."
All of the Administrators are a part of the jira-administrators group. They are also a part of the jira-servicedesk-users group. Removing them from jira-servicedesk-users, restarting Jira and leaving them only in jira-administrators, did not resolve the issue.
We're wondering if there's anything else to do, rather than do a complete uninstall and re-install, starting from scratch - again.
Any and all help is appreciated. Thanks!