Synopsis:
- Suse Linux 15.1.20190513 running in a VM
- Have Git 2.16.4 installed
- Have PostgreSQL installed
- Have phpPgAdmin installed
using bitbucket 6.5.1 installer bin, it goes through the process without error but then fails to start bitbucket. There is no diagnostic output. This is a clean install of SuSE (3rd attempt!)
Running ./start-bitbucket.sh shows the following.....note that the log directory is not created/does not exist. (Manually creating it doesn't help)
Starting Atlassian Bitbucket as dedicated user atlbitbucket
Copying Elasticsearch configuration to /var/atlassian/application-data/bitbucket/shared/search
mkdir: cannot create directory '/var/atlassian/application-data/bitbucket/shared/search': Permission denied
mv: cannot stat '/var/atlassian/application-data/bitbucket/shared/search/elasticsearch.yml':No such file or directory
mv: cannot stat '/var/atlassian/application-data/bitbucket/shared/search/logging.yml': No such file or directory
cp: cannot create regular file '/var/atlassian/application-data/bitbucket/shared/search': Permission denied
cp: cannot create regular file '/var/atlassian/application-data/bitbucket/shared/search': Permission denied
cp: cannot create regular file '/var/atlassian/application-data/bitbucket/shared/search': Permission denied
Setting Elasticsearch configuration to version 3
/opt/Atlassian/bitbucket/6.5.1/bin/_start-search.sh: line 40: /var/Atlassian/application-data/bitbucket/shared/search/.version: No such file or directory
mkdir: cannot create directory '/var/atlassian/application-data/bitbucket/tmp/search': Permission denied
/var/atlassian/application-data/bitbucket/tmp/search could not be created. Permissions issue?
The bundled Elasticsearch was not started
Bitbucket is being run with a umask that contains potentially unsafe settings.
The following issues were found with the mask "u=rwx,g=rx,o=rx" (0022):
- Access is allowed to 'others'. It is recommended that 'others' be denied
all access for security reasons.
The recommended umask for Bitbucket is "u=,g=w,o=rwx" (0027) and can be
configured in _start-webapp.sh
The current open files limit is set to less than 4096
Attempting to increase limit...
Limit increased to 4096 open files
Starting Bitbucket webapp at http://localhost:7900
/opt/Atlassian/bitbucket/6.5.1/bin/_start-webapp.sh: line 106: /var/Atlassian/application-data/bitbucket/log/bitbucket.pid: Permission denied
There was a problem starting the Bitbucket webapp
/opt/Atlassian/bitbucket/6.5.1/bin/_start-webapp.sh: line 105: /var/Atlassian/application-data/bitbucket/log/launcher.log: Permission denied