I am trying to setup a server with Apache (as https proxy) Jira and Confluenece.
Currently Jira works like a charm, but Confluence refuses to work.
If I call confluence.mydomain.com I get an 503 Error.
Confluence error log shows an NullPointerException in org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183) that stops concfluence to start.
apache confluence:
<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerName confluence.mydomain.com
ServerAdmin webmaster@localhost
ProxyPreserveHost On
<Proxy *>
Order allow,deny
Allow from all
</Proxy>
ProxyPass / http://localhost:8090/
ProxyPassReverse / http://localhost:8090/
ErrorLog ${APACHE_LOG_DIR}/confluence-error.log
CustomLog ${APACHE_LOG_DIR}/confluence-access.log combined
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/mydomain.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mydomain.com/privkey.pem
</VirtualHost>
</IfModule>
Confluence server.xml
<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"
scheme="https" secure="true" proxyName="confluence.mydomain.com" proxyPort="443"/>
catalania.log
08-Jul-2019 11:28:25.475 WARNUNG [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server] failed to set property [debug] to [0]
08-Jul-2019 11:28:25.526 WARNUNG [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'debug' to '0' did not find a matching property.
08-Jul-2019 11:28:25.545 WARNUNG [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine] failed to set property [debug] to [0]
08-Jul-2019 11:28:25.551 WARNUNG [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host] failed to set property [debug] to [0]
08-Jul-2019 11:28:25.580 WARNUNG [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host/Context] failed to set property [debug] to [0]
08-Jul-2019 11:28:25.596 WARNUNG [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Engine/Host/Context] failed to set property [debug] to [0]
08-Jul-2019 11:28:25.806 INFORMATION [main] org.apache.coyote.AbstractProtocol.init Initialisiere ProtocolHandler["http-nio-8090"]
08-Jul-2019 11:28:25.830 INFORMATION [main] org.apache.catalina.startup.Catalina.load Server initialization in [426] milliseconds
08-Jul-2019 11:28:25.835 INFORMATION [main] org.apache.catalina.core.StandardService.startInternal Starting service [Tomcat-Standalone]
08-Jul-2019 11:28:25.835 INFORMATION [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet engine: [Apache Tomcat/9.0.19]
08-Jul-2019 11:28:26.450 SCHWERWIEGEND [main] org.apache.catalina.core.ContainerBase.startInternal A child container failed during start
java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Standalone].StandardHost[localhost].StandardContext[]]
...
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException
at org.apache.tomcat.util.scan.StandardJarScanner.process(StandardJarScanner.java:373)
at org.apache.tomcat.util.scan.StandardJarScanner.scan(StandardJarScanner.java:191)
at org.apache.catalina.startup.ContextConfig.processJarsForWebFragments(ContextConfig.java:1956)
at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1122)
at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:768)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:301)
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:123)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5048)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
... 9 more
08-Jul-2019 11:28:27.889 INFORMATION [main] org.apache.coyote.AbstractProtocol.pause Pausing ProtocolHandler ["http-nio-8090"]
08-Jul-2019 11:28:27.889 INFORMATION [main] org.apache.catalina.core.StandardService.stopInternal Stopping service [Tomcat-Standalone]
08-Jul-2019 11:28:27.890 INFORMATION [main] org.apache.coyote.AbstractProtocol.destroy Destroying ProtocolHandler ["http-nio-8090"]
08-Jul-2019 11:28:27.892 INFORMATION [Catalina-utility-3] org.apache.catalina.core.ApplicationContext.log Destroying Spring FrameworkServlet 'dispatcher'
08-Jul-2019 11:28:27.892 INFORMATION [Catalina-utility-3] org.springframework.web.context.support.AnnotationConfigWebApplicationContext.doClose Closing WebApplicationContext for namespace 'dispatcher-servlet': startup date [Mon Jul 08 11:28:27 CEST 2019]; root of context hierarchy
08-Jul-2019 11:28:27.893 INFORMATION [Catalina-utility-3] org.springframework.context.support.DefaultLifecycleProcessor.stop Stopping beans in phase 2147483647
08-Jul-2019 11:28:27.896 INFORMATION [Catalina-utility-3] org.springframework.scheduling.concurrent.ThreadPoolTaskScheduler.shutdown Shutting down ExecutorService 'defaultSockJsTaskScheduler'