Hello
I have a problem with the backup client (https://confluence.atlassian.com/bitbucketserver/using-the-bitbucket-server-backup-client-776640064.html)
I can't restore the bitbucket data because of this error:
2019-07-05 00:04:43,673 ERROR Unable to insert into table cwd_user_attribute data [id=163843, user_id=131073, directory_id=32769, attribute_name=lastAuthenticationTimestamp, attribute_value=1553691165395, attribute_lower_value=1553691165395, attribute_numeric_value=1553689908679] with statement insert into PUBLIC.cwd_user_attribute (id, user_id, directory_id, attribute_name, attribute_value, attribute_lower_value, attribute_numeric_value) values (?, ?, ?, ?, ?, ?, ?)
2019-07-05 00:04:43,808 ERROR bitbucket-20190327-145310-295.tar could not be restored
com.atlassian.stash.internal.backup.liquibase.LiquibaseChangeExecutionException: Failed to execute change: Inserts data into an existing table; nested exception is java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: ATTRIBUTE_NUMERIC_VALUE
at com.atlassian.stash.internal.backup.liquibase.DefaultLiquibaseDao.insert(DefaultLiquibaseDao.java:306)
at com.atlassian.stash.internal.backup.liquibase.DatabaseUpdater.onChangesetContent(DatabaseUpdater.java:63)
It seems that in the back-up archive i have an insert with that column but when the table is created the column is missing. If i start a new instance of bitbucket i have that column.
I've tried to edit the backup archive and remove that insert but after i created the archive again i get this error:
Caused by: java.lang.IllegalArgumentException: Invalid byte 86 at offset 7 in '6nFVNvV' len=8
at org.apache.commons.compress.archivers.tar.TarUtils.parseOctal(TarUtils.java:130)
at org.apache.commons.compress.archivers.tar.TarUtils.parseOctalOrBinary(TarUtils.java:175)
at org.apache.commons.compress.archivers.tar.TarArchiveEntry.parseTarHeader(TarArchiveEntry.java:942)
at org.apache.commons.compress.archivers.tar.TarArchiveEntry.parseTarHeader(TarArchiveEntry.java:931)
at org.apache.commons.compress.archivers.tar.TarArchiveEntry.<init>(TarArchiveEntry.java:324)
at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.getNextTarEntry(TarArchiveInputStream.java:242)
and i'm guessing that is because i created the archive manually.
Can you help me with a solution for this.
This is my only backup and it worked like a charm 2 months ago, but i encountered a problem and i lost the database, so when i try to restore the data i encounter those problems.
Thanks