I'm not sure but I gess Jira need to check the license every day,
My question is: How to increase the timeout for the checking license service?
My jira server die every beginning of day with error:
Cannot initialize ExtendedSystemInfoUtilsImpl
com.atlassian.jira.util.dbc.Assertions$NullArgumentException: jiraLicenseService should not be null!
at com.atlassian.jira.util.dbc.Assertions.notNull(Assertions.java:29)
at com.atlassian.jira.util.system.ExtendedSystemInfoUtilsImpl.<init>(ExtendedSystemInfoUtilsImpl.java:152)
at com.atlassian.jira.util.system.ExtendedSystemInfoUtilsImpl.<init>(ExtendedSystemInfoUtilsImpl.java:159)
at com.atlassian.jira.web.servlet.InternalServerErrorServlet.initializeInternalServerErrorDS(InternalServerErrorServlet.java:147)
at com.atlassian.jira.web.servlet.InternalServerErrorServlet.doRequest(InternalServerErrorServlet.java:68)
at com.atlassian.jira.web.servlet.InternalServerErrorServlet.doGet(InternalServerErrorServlet.java:110)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:728) <+55> (ApplicationFilterChain.java:305) (ApplicationFilterChain.java:210) (XContentTypeOptionsNoSniffFilter.java:22) (AbstractHttpFilter.java:31) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (HeaderSanitisingFilter.java:44) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ServletFilterModuleContainerFilter.java:71) (ServletFilterModuleContainerFilter.java:63) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ServletFilterModuleContainerFilter.java:71) (ServletFilterModuleContainerFilter.java:63) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ServletFilterModuleContainerFilter.java:71) (ServletFilterModuleContainerFilter.java:63) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (GzipFilter.java:80) (GzipFilter.java:51) (JiraGzipFilter.java:55) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ServletFilterModuleContainerFilter.java:71) (ServletFilterModuleContainerFilter.java:63) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ChainedFilterStepRunner.java:87) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (MultipartBoundaryCheckFilter.java:41) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ChainedFilterStepRunner.java:87) (JiraFirstFilter.java:57) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (ApplicationDispatcher.java:749) (ApplicationDispatcher.java:489) (ApplicationDispatcher.java:412) (ApplicationDispatcher.java:339) (StandardHostValve.java:467) (StandardHostValve.java:338) (StandardHostValve.java:428) (StandardHostValve.java:201) (ErrorReportValve.java:100) (StandardEngineValve.java:118) (AccessLogValve.java:953) (CoyoteAdapter.java:408) (AbstractHttp11Processor.java:1041) (AbstractProtocol.java:603) (JIoEndpoint.java:310)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
My server is local server with a verrrrry slow internet connection, I think jira cannot start the jiraLicenseService because it had timeout.
Beginning of every day, I have to plugins the fastest internet line to the jira server then restart it to make the jira running. So some reason, I cannot keep that line for whole day.
Thanks,
DuongTC