This is a new bitbucket server. I was able to go through atlassian documentation to set up the server without ssl. I am trying to get it to run over ssl but with no luck. Here are my parameters that I am trying to use for my bitbucket.properties file:
server.require-ssl=true
server.additional-connector.1.port=7990
server.additional-connector.1.redirect-port=443
server.port=7990
server.connection-timeout=20000
server.redirect-port=443
server.compression.mime-types=text/css,text/html,text/javascript,text/json,text/plain,text/xml,text/x-javascript,\application/javascript,application/json,application/x-javascript,application/vnd.git-lfs+json
server.secure=true
server.ssl.enabled=true
server.ssl.key-alias=salesgit
server.ssl.key-store=d:/keystore/salesgit-keystore.jks
server.ssl.key-store-password=XXXXXXXX
server.ssl.protocol=TLSv1.2
server.ssl.key-store-type=jks
server.ssl.client-auth=need
server.address=X.X.X.X
As a reminder, this is not a migration. This is a new instance.
I am running this as a windows service. So when I try to start the service, it stops after about 30 seconds.
The error I get states that the service failed to start on port 7990:
Caused by: org.springframework.boot.web.embedded.tomcat.ConnectorStartFailedException: Connector configured to listen on port 7990 failed to start
Any assistance is greatly appreciated.