Hi,
today i tried to update our linux Confluence Installation from 6.3.1 to 6.15.4, which failed.
The update said, i hava to take care of the server.xml myself. Since the "more information" Link (http://docs.atlassian.com/confluence/docs-6.15.4/Upgrading+Confluence#UpgradingConfluence-custommodifications) is broken, i just took the old server.xml file.
With the "new" or the "old" server.xml i get an Error 503 when trying to go to the confluence webpage.
I then checked the logs, where i only found:
[Thu May 23 14:34:35 2019] [error] (111)Connection refused: proxy: HTTPS: attempt to connect to 10.10.150.226:8443 (confluence.xxxx) failed
I then started confluence manually in the foreground. I then noticed this:
Caused by: java.io.FileNotFoundException: /opt/atlassian/confluence/conf/confluence.keystore (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.
and this:
23-May-2019 14:59:33.436 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-10.10.150.226-8090"]
23-May-2019 14:59:33.454 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["https-jsse-nio-10.10.150.226-8443"]
23-May-2019 14:59:33.594 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to initialize component [Connector[HTTP/1.1-8443]]
org.apache.catalina.LifecycleException: Protocol handler initialization failed
at org.apache.catalina.connector.Connector.initInternal(Connector.java:983)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:535)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
at the beginning of the update i noticed:
Added files:
confluence/WEB-INF/classes/log4j-diagnostic.properties
conf/confluence.keystore
conf/server.xml.back
funny thing is, that "confluence.keystore" is nowhere to be found on the whole server (the update said it was successful).
Since my colleagues needed access to confluence again, i did a rollback.
What do i need to do here?
Thanks and best regards
Sebastian