Our SSL cert is expiring and i'm having trouble importing a new cert. We have a wildcard cert *.domain.com that we use for all other sites, but i'm getting an error when i try to start up Jira.
I've created a new keystore and imported all new certs (root, intermediate,cert) and then updated server.xml to point at this new keystore. No errors during the keytool import. When i start up atlassian jira service, i'm seeing this error in the catalina log:
SEVERE: Failed to start connector Connector HTTP/1.1-443
LifecycleException: service.getName(): Catalina; Protocol handler start failed: java.io.IOException: jsse.invalid_ssl_conf
I know this is more of a tomcat issue than jira, but after spending a few hours on this, i'm stuck.
Any help would be appreciated.
Thanks,
Matt