Intermittently some clients in our organization will get a completely blank page when they attempt to load our Service Desk portal. We've done a lot of research and troubleshooting that I won't get in to as I believe we've finally managed to determine the cause, but actually discerning how to fix it is giving us some grief. One quick thing worth mentioning is that we've been using Service Desk for about a year, and this only started happening after we upgraded from a 3.x.x version of Service Desk to 4.1.0.
After generating a HAR file when a user's service desk portal fails to load and comparing it to one that successfully loads, we've noticed in the failed HAR filethat we receive a "401" error response for a specific POST request, and then nothing further is generated in the HAR. In the HAR file for the successful load, the same POST request provides a successful "200" response, and then more POST and GET requests occur until the page successfully loads.
The 401 error that occurs is always for the following URL:
POST https://jiraurl.com:9999/rest/webResources/1.0/resources
We've found this Atlassian article that may be relevant, but we're not exactly sure how to go about applying/testing any possible changes from it:
https://developer.atlassian.com/server/framework/atlassian-sdk/rest-and-os-authtype/
Any further information needed for help/suggestions can be provided, although I'd prefer not to share the HAR files publicly for security reasons.
Thanks for the help!