Jira's Active Directory connection randomly fails with errors similar to the following:
2015-05-12 15:52:03,484 http-bio-8443-exec-7 ERROR anonymous 950x104x2 10ml984 10.40.104.81,127.0.0.1 /login.jsp [crowd.manager.application.ApplicationServiceGeneric] Directory 'Active Directory server' is not functional during authentication of 'auserid'. Skipped.
2015-05-12 15:53:02,254 http-bio-8443-exec-11 ERROR anonymous 951x105x3 10ml984 10.40.104.81,0:0:0:0:0:0:0:1 /login.jsp [crowd.manager.application.ApplicationServiceGeneric] Directory 'Active Directory server' is not functional during authentication of 'auserid'. Skipped.
I can immediately do an LDAP query against AD on the same machine and get a response. So, AD is responding just fine:
$ ldapsearch -LLL -x -b "OU=Accounts,DC=example,DC=com" -h 10.10.2.2 "SAMAccountName=auserid" | grep ^uid:
uid: auserid
So, can Atlassian tell me what might be going on, and what can I do to get JIRA to authenticate against AD consistently?
Thanks,
Kurt