We had to do a forceful shutdown on our confluence server and after it came up, then mysql wouldn't start all the way. It just keeps trying to start and I see these messages in the /var/mysql/*log:
120807 14:20:19 ERROR Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
120807 14:20:29 Warning Setting lower_case_table_names=2 because file system for /var/mysql/ is case insensitive
InnoDB: The InnoDB memory heap has been disabled.
InnoDB: Mutex and rw_lock use GCC atomic builtins.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
120807 14:20:29 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
120807 14:20:29 InnoDB: Started; log sequence number 0 43655
120807 14:20:29 ERROR Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist