HELLO,
I'm doing JIRA Server (centos6.5)-> Server (centos7.3) Migration ,when I use XML backupfile to restore data ,it show me:
JIRA had problems starting up
This page is for JIRA administrators. If you're seeing this page, your JIRA administrator is probably working to restore the service.
the log below:
- JiraImportTaskExecutionThread-1 ERROR root 1025x34x1 15p19z3 192.168.2.167 /secure/admin/XmlRestore.jspa [c.a.upgrade.core.DefaultUpgradeTaskFactoryProcessor] Upgrade task [host,buildNumber=77001] failed
java.lang.RuntimeException: Error running original upgrade task - Caused by: com.querydsl.core.QueryException: Caught SQLException for delete from clusteredjob
where clusteredjob.id not in (select max(jobs.id)
from (select preload.id, preload.job_id
from clusteredjob preload) as jobs
group by jobs.job_id)
- Caused by: java.sql.SQLException: You can't specify target table 'clusteredjob' for update in FROM clause
the enviroment:
jira:7.9-->7.9
OS: centos6.5--->7.3
mysql:5.7.8--->5.7.8
mysql-connect: mysql-connector-java-5.1.47.jar
my xml backfile like this:
JIRA-backup-zip-file
├── activeobjects.<span>xml</span>
<span>├── entities</span>.<span>xml</span>
who can help me how to solve it,thank you.