We are running on Confluence 5.4.2 and have setup our production system; we are using Zen Foundation for the design of the site and during configuring the system and designing the spaces, etc. everything worked fine.
After a restart of the server we encounter a major problem:
- The UPM is disabled after startup
- There Zen Foundation is disabled after startup
This leads to the following behaviours (excerpt from logfile):
- 2014-05-21 16:32:22,353 WARN [http-8221-4] [atlassian.confluence.themes.DefaultThemeManager] extractTheme Unable to find configured theme module: com.zenfoundation:zen-theme
- 2014-05-21 16:33:43,811 ERROR [http-8221-3] [renderer.v2.components.MacroRendererComponent] processMacro Unexpected error formatting macro: subspace_breadcrumbs
java.lang.NullPointerException
- com.atlassian.plugin.web.renderer.RendererException: No renderer found for resource type: soy
We already emptied the cache folders (after shutdown) and increased -Datlassian.plugins.enable.wait in the JVM environment, but no effect;
but as we are running on a high end machine, this should not be the problem
Once the system is up, I'm able to manually enable UPM and Zen Foundation, but the system will not display the menu and bring the SOY-erros.
Any idea on that problem?
Thanks in advance,
Martin