I have a new install of Jira Service Desk 8,0. When I switch to http redirect to https I receive the message in the stdout log:
JIRA-Bootstrap ERROR [c.a.jira.startup.DefaultJiraLauncher] JIRA has failed to start because of the following errors: [(Event: Level = (EventLevel: error) , Key = (EventType: setup) , Desc = Tomcat is misconfigured , Exception = The server.xml file is missing parameters needed by Jira to handle requests that contain special characters.<br/>)]
I see this in the access.log
"GET /secure/johnson/data HTTP/1.1" 503 5 270
The error page I see in the browser shows that the installed certificate is valid,
I tried updating the server.xml from this article:
https://confluence.atlassian.com/jirakb/changing-server-xml-to-handle-requests-with-special-characters-958453799.html
This is on Windows 2016 server with SQL Server 2014 and regular http works with no issues.